Document Check - Intermittent Issues

Incident Report for ComplyCube

Resolved

This incident has been resolved.
Posted Jun 17, 2021 - 15:06 UTC

Investigating

Our Document Check service is currently experiencing intermittent issues for a subset of our users in the EU.

We are actively working on resolving this.
Posted Jun 17, 2021 - 14:17 UTC
This incident affected: Europe (Document Checks).