Document Check - Intermittent Issues
Incident Report for ComplyCube
Resolved
This has been resolved.
Posted Aug 08, 2022 - 15:07 UTC
Investigating
Our Document Check service is currently experiencing intermittent issues for a subset of our users.

We are actively working on resolving this.
Posted Aug 08, 2022 - 14:46 UTC
This incident affected: Europe (Document Checks).