AWS are investigating increased invoke error rates - Advisory
Incident Report for ComplyCube
Resolved
This incident has been resolved.
Posted Dec 01, 2021 - 22:51 UTC
Investigating
We are monitoring the situation in case our services are impacted.
Posted Nov 24, 2021 - 19:47 UTC
This incident affected: Europe (Identity Checks), US (Identity Checks), and Middle East (Identity Checks).